Welcome to Cadabra Q&A, where you can ask questions and receive answers from other members of the community.
0 votes

When I do the 'cmake ..' in Mac with the updated repository from
github, an error is coming. I don't know what wrong.
enter image description here
...
enter image description here

asked in Installation trouble by (400 points)

2 Answers

+1 vote
 
Best answer

This should now be fixed with the version in github. You will still get warnings from CMake about things related to the 'boost' library, but it should no longer produce errors.

answered by (50.9k points)
selected by

CMake works fine. However, it produces an error when do the Make as following.
enter image description here

Did you do

brew install gmp

before this? If you did, can you check that

/usr/local/include/gmp.xx.h

exists and is readable? If not, try locating the gmpxx.h file on your system and let me know where it ended up.

After I update the newest git repository and update the Homebrew and do the following

brew doctor
sudo chown -R $(whoami) /usr/local

, I finally can build with the standard without any errors (but some warnings remain during the make and sudo make install).

+2 votes

Yeah, I'm aware of that, something has changed in homebrew which makes the cmake stage fail. Haven't yet had the time to look into this (they most likely renamed the 'ossp-uuid' package).

answered by (50.9k points)

Up to now, I still can not install. The problem remains.

...