Welcome to Cadabra Q&A, where you can ask questions and receive answers from other members of the community.
0 votes

Hello,

I just did a system upgrade from linux minnt 17.1 to linux mint 18.3. I wanted to upgrade only to version 18 so that I can install cadabra using the binary you provide, but our system admin told me there should no problem if go all the way to 18.3. Installation of cadabra2 was indeed ok, all dependencies were satisfied, but when I try to run cadabra2-gtk I get the following error:

cadabra2-gtk: error while loading shared libraries: libboost_filesystem.so.1.54.0: cannot open shared object file: No such file or directory

The library seems to exist, but somehow Cadabra can not open it.

Do you know what is the reason for this and how I can solve it?

Tanks,
Andrei

asked in Installation trouble by

1 Answer

0 votes

Are you sure it is trying to start the cadabra2-gtk installed by the binary package? That one is linked to version 1.58 of the boost libraries, and should work (all Mint 18.x have version 1.58).

If you previously installed from source, you would have ended up with a cadabra2-gtk linked to version 1.54 (as that's what Mint 17.x uses). So you may need to erase all cadabra related things in /usr/local/bin and /usr/local/lib, i.e.

rm -f /usr/local/bin/cadabra*
rm -f /usr/local/lib/*cadabra*

Let me know if that helps.

answered by (50.9k points)

Thanks, that helped.

Andrei

...