Welcome to Cadabra Q&A, where you can ask questions and receive answers from other members of the community.
0 votes

Hi;
I installed Fedora version of Cadabra from Cadabra website cadabra2-2.1.4-fedora24.rpm. Installed using rpm. However when i click to run it from the installation directory it does not run. Window comes and then disappears within miliseconds.
Can anyone help.

Regards,

Ashish Arya

asked in Installation trouble by

1 Answer

0 votes

Can you run it from a terminal window (cadabra2-gtk) and let me know if it spits out any errors?

answered by (50.9k points)

This is outcome after cadabra2-gtk command

[root@acer ~]# cadabra2-gtk
cadabra-client: spawning server
cadabra-client: scale = 1
terminate called after throwing an instance of 'std::runtimeerror'
what(): Traceback (most recent call last):
File "", line 1, in
File "cadabra2
defaults.py", line 7, in
import cadabra2
ImportError: libpcrecpp.so.0: cannot open shared object file: No such file or directory

terminate called after throwing an instance of 'std::logic_error'
what(): Failed to read port from server.
Aborted (core dumped)
[root@acer ~]#

regards,

It seems that Fedora 26 has upgraded the pcre library and removed the old version. I'll need to build new packages against Fedora 26 (the packages available right now are Fedora 24 packages). I'll try to set this up tonight.

You may want to try to build from source, that should work.

Can you give the package in https://cadabra.science/packages/fedora26/ a shot and let me know if that one works?

Hello;
This is outcome of installation on Fedora 26.

[root@acer Downloads]#  rpm -i cadabra2-2.1.6-fedora26.rpm
error: Failed dependencies:
    boost-filesystem is needed by cadabra2-2.1.6-1.x86_64
    boost-system is needed by cadabra2-2.1.6-1.x86_64
    libboost_filesystem.so.1.63.0()(64bit) is needed by cadabra2-2.1.6-1.x86_64
    libboost_program_options.so.1.63.0()(64bit) is needed by cadabra2-2.1.6-1.x86_64
    libboost_python3.so.1.63.0()(64bit) is needed by cadabra2-2.1.6-1.x86_64
    libboost_regex.so.1.63.0()(64bit) is needed by cadabra2-2.1.6-1.x86_64
    libboost_system.so.1.63.0()(64bit) is needed by cadabra2-2.1.6-1.x86_64
    libpython3.6m.so.1.0()(64bit) is needed by cadabra2-2.1.6-1.x86_64
    python(abi) = 3.6 is needed by cadabra2-2.1.6-1.x86_64

Thanks for efforts

regards,

Ashish

The rpm command doesn't install dependencies if you invoke it that way. Better use the dnf tool (which is rpm's successor), that is

sudo dnf install cadabra2-2.1.6-fedora26.rpm
...