Welcome to Cadabra Q&A, where you can ask questions and receive answers from other members of the community.
0 votes

Dear Dr. Peeters,

I am trying to install Cadabra 2.x on Ubuntu 16.04 which is running inside the Windows 10 using VirtualBox. I installed Cadabra 1.39 first successfully but during the installation of Cadabra 2.x I receive the following error. It's about dependencies but I checked these packages and all of them are installed.

vahid@vahid-VirtualBox:~/Downloads$ sudo dpkg -i cadabra2-2.0.794.f14aa68-trusty.deb
[sudo] password for vahid:
(Reading database ... 286141 files and directories currently installed.)
Preparing to unpack cadabra2-2.0.794.f14aa68-trusty.deb ...
Unpacking cadabra2 (2.0.794.f14aa68) over (2.0.794.f14aa68) ...
dpkg: dependency problems prevent configuration of cadabra2:
cadabra2 depends on libpcrecpp0; however:
Package libpcrecpp0 is not installed.
cadabra2 depends on libboost-python1.54.0; however:
Package libboost-python1.54.0 is not installed.
cadabra2 depends on libboost-system1.54.0; however:
Package libboost-system1.54.0 is not installed.
cadabra2 depends on libboost-filesystem1.54.0; however:
Package libboost-filesystem1.54.0 is not installed.
cadabra2 depends on libboost-program-options1.54.0; however:
Package libboost-program-options1.54.0 is not installed.
cadabra2 depends on libboost-regex1.54.0; however:
Package libboost-regex1.54.0 is not installed.
cadabra2 depends on libgtkmm-3.0-1; however:
Package libgtkmm-3.0-1 is not installed.
cadabra2 depends on python3-matplotlib; however:
Package python3-matplotlib is not installed.
cadabra2 depends on python3-mpmath; however:
Package python3-mpmath is not installed.
cadabra2 depends on python-sympy; however:
Package python-sympy is n
dpkg: error processing package cadabra2 (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160523-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
cadabra2

Regards
Vahid

asked in Installation trouble by (1.1k points)

1 Answer

+2 votes
 
Best answer

As the package name indicates, it is meant to be installed on Ubuntu Trusty, that is, 14.04, not 16.04. I have simply not yet had the time to make a package for 16.04 yet.

answered by (50.9k points)
selected by

Thanks for reply.
You are right. I didn't aware of the incompatibility.

...