Welcome to Cadabra Q&A, where you can ask questions and receive answers from other members of the community.
0 votes

I am facing the following problem (pasted below) during cmake. I have installed and linked glib (also performed each and every step described in GitHub instructions)
brew doctor found no unlinked or non-writable directories.

please help?

---
-- Building 2.1.3
-- Build id 1244.c7e61aaee dated 2017-04-06
-- User mode
-- Building for use with Python 3 (good!)
-- CMake version = 3.7.2
-- Looking for versions: 3.6;3.4;3.3;3.2;3.1;3.0;2.7;2.6;2.5;2.4;2.3;2.2;2.1;2.0;1.6;1.5
-- Looking for python version '3.6' by checking executables: python;python3;python3.6.
-- Found executable /usr/bin/python with UNsuitable version 2.7.10
-- Found executable /usr/local/bin/python3 with suitable version 3.6.1
-- Python version = 3.6.1
CMake Warning at /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindBoost.cmake:1518 (message):
  No header defined for python3; skipping header check
Call Stack (most recent call first):
  core/CMakeLists.txt:50 (find_package)


-- Boost version: 1.63.0
-- Found the following Boost libraries:
--   python3
--   regex
-- Found gmp /usr/local/lib/libgmp.dylib
-- Found gmpxx /usr/local/lib/libgmpxx.dylib
-- Found python /usr/local/opt/python3/Frameworks/Python.framework/Versions/3.6/lib/libpython3.6.dylib
-- Python include dirs: /usr/local/Cellar/python3/3.6.1/Frameworks/Python.framework/Versions/3.6/include/python3.6m
-- Python site path at /usr/local/Cellar/python3/3.6.1/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages
-- Packages built in /Users/Abacus/cadabra2/build/core/packages/cdb
--    relativity___init__
--    relativity_schwarzschild
--    gauge_theory___init__
--    gauge_theory_instantons
-- Looking for versions: 3.6;3.4;3.3;3.2;3.1;3.0;2.7;2.6;2.5;2.4;2.3;2.2;2.1;2.0;1.6;1.5
-- Looking for python version '3.6' by checking executables: python;python3;python3.6.
-- Found executable /usr/bin/python with UNsuitable version 2.7.10
-- Found executable /usr/local/bin/python3 with suitable version 3.6.1
-- Found python /usr/local/opt/python3/Frameworks/Python.framework/Versions/3.6/lib/libpython3.6.dylib
-- Checking for module 'glibmm-2.4'
--   No package 'glibmm-2.4' found
CMake Error at /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindPkgConfig.cmake:415 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindPkgConfig.cmake:588 (_pkg_check_modules_internal)
  client_server/CMakeLists.txt:45 (pkg_check_modules)


-- Configuring incomplete, errors occurred!
See also "/Users/Abacus/cadabra2/build/CMakeFiles/CMakeOutput.log".
asked in Installation trouble by (300 points)

1 Answer

0 votes

Can you try erasing your build directory completely, creating a fresh one, and then running cmake again?

answered by (50.9k points)

Thank you for your reply. I have done as you instructed. But the same problem persists. I don't know whether this might have something to do with or not but the glib in my mac is 2.52.0.

Did you perhaps install glibmm by hand from source? If you do

brew install gtkmm3

(as in the cadabra build instructions) it will install glibmm-2.4 just fine.

I haven't tried building against glibmm-2.5 yet, or against gtkmm-3.89 for that matter.

Thank you for your reply.
I have once again run

brew install gtkmm3

in the terminal. After its completion, I have erased the build directory and tried to cmake again, now the following error is showing.

---
-- The C compiler identification is AppleClang 8.1.0.8020041
-- The CXX compiler identification is AppleClang 8.1.0.8020041
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/cc
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/c++
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Building 2.1.3
-- Build id 1244.c7e61aaee dated 2017-04-06
-- User mode
-- Building for use with Python 3 (good!)
-- CMake version = 3.7.2
-- Found PythonInterp: /Users/Abacus/Downloads/yes/bin/python3 (found suitable version "3.6", minimum required is "3.4") 
-- Looking for versions: 3.6;3.4;3.3;3.2;3.1;3.0;2.7;2.6;2.5;2.4;2.3;2.2;2.1;2.0;1.6;1.5
-- Looking for python version '3.6' by checking executables: python;python3;python3.6.
-- Found executable /Users/Abacus/Downloads/yes/bin/python with suitable version 3.6.0
-- Could NOT find PythonLibs (missing:  PYTHON_LIBRARIES) (found version "3.6")
-- Python version = 3.6
CMake Warning at /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindBoost.cmake:1518 (message):
  No header defined for python3; skipping header check
Call Stack (most recent call first):
  core/CMakeLists.txt:50 (find_package)


-- Boost version: 1.63.0
-- Found the following Boost libraries:
--   python3
--   regex
-- Found gmp /usr/local/lib/libgmp.dylib
-- Found gmpxx /usr/local/lib/libgmpxx.dylib
-- Found python PYTHON_LIBRARY-NOTFOUND
-- Python include dirs: /Users/Abacus/Downloads/yes/include/python3.6m
-- Found PCRE: /usr/local/lib/libpcrecpp.dylib  
-- Python site path at /Users/Abacus/Downloads/yes/lib/python3.6/site-packages
-- Packages built in /Users/Abacus/cadabra2/build/core/packages/cdb
--    relativity___init__
--    relativity_schwarzschild
--    gauge_theory___init__
--    gauge_theory_instantons
-- Looking for versions: 3.6;3.4;3.3;3.2;3.1;3.0;2.7;2.6;2.5;2.4;2.3;2.2;2.1;2.0;1.6;1.5
-- Looking for python version '3.6' by checking executables: python;python3;python3.6.
-- Found executable /Users/Abacus/Downloads/yes/bin/python with suitable version 3.6.0
-- Could NOT find PythonLibs (missing:  PYTHON_LIBRARIES) (found version "3.6")
-- Found python PYTHON_LIBRARY-NOTFOUND
-- Found PkgConfig: /usr/local/bin/pkg-config (found version "0.29.2") 
-- Checking for module 'glibmm-2.4'
--   Found glibmm-2.4, version 2.50.1
CMake Warning at /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindBoost.cmake:1518 (message):
  No header defined for python3; skipping header check
Call Stack (most recent call first):
  client_server/CMakeLists.txt:53 (find_package)


-- Boost version: 1.63.0
-- Found the following Boost libraries:
--   python3
CMake Warning at /usr/local/Cellar/cmake/3.7.2/share/cmake/Modules/FindBoost.cmake:1518 (message):
  No header defined for python3; skipping header check
Call Stack (most recent call first):
  client_server/CMakeLists.txt:55 (find_package)


-- Boost version: 1.63.0
-- Found the following Boost libraries:
--   python3
--   system
--   regex
--   program_options
-- Checking for module 'gtkmm-3.0'
--   Found gtkmm-3.0, version 3.22.0
-- Building GTK3 user interface
-- Installing LaTeX style files in /usr/local/texlive/texmf-local/tex/latex/cadabra2
-- Boost version: 1.63.0
-- Found the following Boost libraries:
--   system
--   filesystem
-- Boost version: 1.63.0
-- Found the following Boost libraries:
--   system
-- Configuring self-tests
-- Set PYTHONPATH for testing to /Users/Abacus/cadabra2/core:/Users/Abacus/cadabra2/build/core/packages:/Users/Abacus/cadabra2/build/core:
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
PYTHON_LIBRARY (ADVANCED)
    linked by target "cadabra2" in directory /Users/Abacus/cadabra2/core
    linked by target "cadabra2python" in directory /Users/Abacus/cadabra2/core
    linked by target "cadabra_server" in directory /Users/Abacus/cadabra2/client_server
    linked by target "cadabra_client" in directory /Users/Abacus/cadabra2/client_server

-- Configuring incomplete, errors occurred!

please, help.

That log shows that cmake cannot find the python development libraries. Are you sure you ran all of the brew commands listed in the installation instructions?

Thank you for replying. I have once again run all the brew commands (also following StackOverflow tried to link the libraries). But the same problem persists. Really don't know what to do next?

I have made a few small changes to the cmake configuration files. Can you check out the current version from github and give it another shot? Thanks.

Thank you very much for your help. I am really embarrassed to say that the problem still persists. Meanwhile I am using this beautiful software in linux and let me convey my sincere regards to you for creating Cadabra.

...