Welcome to Cadabra Q&A, where you can ask questions and receive answers from other members of the community.
0 votes

Hi,

I'm trying to install cadabra2 on my mac and I keep getting error that I copied below upon doing the cmake. I tried every step a couple of times and all installed well on my operator. I just wonder if you have an idea what the problem can be from?

thank you

build % cmake -DENABLE_MATHEMATICA=OFF ..

-- The C compiler identification is AppleClang 12.0.5.12050022 -- The CXX compiler identification is AppleClang 12.0.5.12050022 -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working C compiler: /Library/Developer/CommandLineTools/usr/bin/cc - skipped -- Detecting C compile features -- Detecting C compile features - done -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /Library/Developer/CommandLineTools/usr/bin/c++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Git found: /usr/bin/git


Building Cadabra version 2.3.9.1 (64-bit)

-- Build id '2803.ce5bc98ee9' dated 2022-02-18 -- Build mode is set to '' -- Install directory set to /usr/local -- Building tweak version -- Building in user mode -- Building tests


Configuring Python

-- Building for use with Python 3 (good!) -- pybind11 v2.9.0 dev1 -- Found PythonInterp: /usr/local/bin/python3.9 (found version "3.9.10") -- Found PythonLibs: /usr/local/opt/python@3.9/Frameworks/Python.framework/Versions/3.9/lib/libpython3.9.dylib -- Performing Test HAS_FLTO -- Performing Test HAS_FLTO - Success -- Performing Test HAS_FLTO_THIN -- Performing Test HAS_FLTO_THIN - Success -- Found python /usr/local/opt/python@3.9/Frameworks/Python.framework/Versions/3.9/lib/libpython3.9.dylib -- Python version is 3.9. -- Installing Python module in /usr/local/lib/python3.9/site-packages -- Python abi name cpython-39-darwin


Configuring Jupyter kernel

-- Building the default Jupyter kernel


Configuring client-server

-- Found PkgConfig: /opt/local/bin/pkg-config (found version "0.29.2") Warning: Use glibmm@2.66 instead of deprecated glibmm@2.64 Warning: Use glibmm@2.66 instead of deprecated glibmm@2.64 Warning: Use pangomm@2.46 instead of deprecated pangomm@2.42 Warning: Use pangomm@2.46 instead of deprecated pangomm@2.42 -- Using PKG_CONFIG_PATH = /usr/local/opt/glibmm@2.66/lib/pkgconfig:/usr/local/opt/cairomm@1.14/lib/pkgconfig:/usr/local/opt/pangomm@2.46/lib/pkgconfig:/usr/local/opt/atkmm@2.28/lib/pkgconfig:/usr/local/opt/libffi/lib/pkgconfig: -- Checking for module 'glibmm-2.4' -- Package 'sigc++-2.0', required by 'glibmm-2.4', not found CMake Error at /opt/local/share/cmake-3.18/Modules/FindPkgConfig.cmake:545 (message): A required package was not found Call Stack (most recent call first): /opt/local/share/cmake-3.18/Modules/FindPkgConfig.cmake:733 (_pkg_check_modules_internal) cmake/modules/FindGLIBMM.cmake:16 (pkg_check_modules) client_server/CMakeLists.txt:18 (find_package)

-- Configuring incomplete, errors occurred! See also "/Users/amirrrezahashemi/Documents/Eonum/cadabra2/build/CMakeFiles/CMakeOutput.log". See also "/Users/amirrrezahashemi/Documents/Eonum/cadabra2/build/CMakeFiles/CMakeError.log".

in General questions by (120 points)

1 Answer

0 votes

A quick brew search sigc++ brings up the libsigc++ package. Try doing

brew install libsigc++

and then do the cmake stage again.

This used to be automatic when installing gtkmm, as the latter requires sigc++, but someone seems to have removed that dependency from the brew repository.

by (64.9k points)
...